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1 Introduction

IQMOL is an open-source molecular editor and visualization package that runs under
Windows, Mac OS X and Linux. It can read a variety of chemical file formats including
xyz, cml, pdb, mol, fchk, cube data and Q-CHEM input/output. It also includes a free-
form molecular builder that allows arbitrary molecular structures to be created. These
structures can be optimized using molecular mechanics force fields and symmetrized to
ensure the structure has the correct point group symmetry. A library of molecules and
functional groups also exists, and these can be used to facilitate building more complicated
molecules.

IQMOL is capable of displaying a variety of molecular properties including atomic charges,
dipole moments and normal modes. Several surface types can be displayed including
molecular orbitals, (spin) densities and van der Waals surfaces. These surfaces can be col-
ored according to an arbitrary scalar field, such as the electrostatic potential. Animations
are also available for vibrational frequencies, and reaction and optimization pathways.

IQMOL can operate as a stand-alone package, but has also been written to work seam-
lessly with the Q-CHEM (http://www.q-chem.com) computational chemistry package. A
comprehensive input file generator, the Q-CHEM User Interface (QUI), provides access
to most of the available options in Q-CHEM, and these options are presented in an in-
tuitive, hierarchical fashion. The generated input files can be submitted to either local
or remote servers that have the Q-CHEM software installed. In particular, a publicly ac-
cessible server is available that allows small (limited to approximately 10 mins) quantum
chemistry calculations to be run without having to purchase and install |Q-CHEM.

1.1 Installation

The latest version of IQMOL| can be downloaded from the website:
http://igmol.org/downloads.html

For Mac (OS X) a disk image file is provided. After downloading, Simply double-click
the disk image to mount it and copy the application to the Applications directory, or any
other desired location.

For Windows an installer is provided that will guide you through the installation process
and will also create a shortcut to the application on your desktop.

For Linux .deb and .rpm packages are now available that can be installed using either
dpkg or yum:

#> sudo dpkg -i igqmol_2.9.0.deb
#> sudo apt-get install -f
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The second command is required to resolve the dependency on the Qt libraries, which
you may not have installed.

#> sudo yum install igmol-2.9.9-2.x86_64.rpm

Note that in either case you will need root permission.

1.2 Overview
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Figure 1.1: The main IQMOL window.

The main IQMOL window is shown in Fig. and comprises the following main parts:

e The Viewer is the main part of the window and is where you can view and interact
with your molecule.
e The Toolbar at the top provides access to common commands and allows selec-

tion between different viewer modes including manipulation D, selection and

building.

e The Model View panel provides a hierarchical view of the data that are available
for the molecule.

e The History panel in the lower left shows a list of the most recent actions than can
be undone, either by clicking on them or by using the Edit » Undo menu option.
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The Model View (MV) provides control over what objects are displayed in the Viewer,
and also allows access to configuration options for these objects. Visibility is controlled
by the associated check-box. Unchecking a check-box causes the item and all its children
to become hidden. If an item does not have a check-box, for example a bond, then its
visibility can only be controlled by items higher in the hierarchy.

The appearance of many objects can be configured by double-clicking the item in the MV.
For example, double-clicking the molecule name brings up the Configure Molecule dialog
which allows you to change the appearance of the molecular structure:

[ JoN ) Configure Molecule

Render
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Bonds

Charges

Smaller Hydrogen Atoms

Reset
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Note that several molecules can be viewed concurrently in the same Viewer and the
appearance of each can be configured separately.

o @k

Figure 1.2: Rendering styles for molecular structures: balls and sticks, wire frame, space
filling, tubes and plastic.



2 Building Molecules

2.1 Adding Atoms and Fragments

By default, IQMOL opens in build mode. This is indicated by a red border around the

button in the Toolbar. The default build atom is indicated by the button and can
be changed by clicking on this button. A pop-up periodic table will appear from which
the desired element type can be selected.

Clicking in the empty Viewer window will create an atom of the current build element.
Additional atoms can be added by clicking on an existing atom and dragging the mouse.
This creates a new atom bonded to the first. To create a disconnected atom, hold down
the alt modifier key when clicking in the Viewer window. (Note that some Linux window
managers use the alt modifier for other purposes. This behavior can be changed using
System Settings » Keyboard » Short-cuts menu).

Bond orders can be increased by clicking and dragging between two existing atoms. If no
bond exists between the two atoms, one is created. Otherwise the bond order is increased.
To decrease the bond order, the bond must first be deleted and a new bond created.

Click and Drag

Figure 2.1: Increasing the bond order.

Functional groups can be added by clicking the button, ensuring the Functional Group
radio button is clicked and selecting the desired group from the menu. Groups are added
in the same way as atoms, i.e. clicking and dragging from an existing atom. The empty
valence is indicated by the yellow bond and shows where the group will be connected.

Entire molecules can also be added to your system by clicking the button, ensuring
the Molecules radio button is clicked, and selecting the desired molecule from the menu.
Be sure to click or the build selection will not be updated. Unlike the other build
modes, clicking anywhere in the viewer window will add the selected molecule (no mouse
modifier is required). This allows several molecules of the same type to be added quickly,
(e.g. for solvation), but changes the usual mouse behavior. If you accidentally add too
many molecules, use the Edit » Undo menu option. When adding molecules, if you click
and hold it is possible to alter the local orientation of the newly added molecule before
being added to the global frame.
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Figure 2.2: The build fragment pop-up that appears when the add fragment button is
clicked.

Once the backbone of the molecule has been drawn, the Add Hydrogens button can
be clicked to automatically add hydrogen atoms to any unfilled valencies.

2.2 Optimizing Structures Using Molecular Mechanics

The builder in IQMOL| is free-form, so your initial structure may look a bit wonky. To

improve the geometry, click the IZJ button. This optimizes the geometry using a molecular
mechanics (MM) force field. The default force field is the Universal Force Field (UFF)[2]
which has the advantage of being defined for almost all of the periodic table. However,
the UFF does not perform well for systems that contain hydrogen bonds and, in these
cases, it is recommended that the force field be changed using the Build » Select Force
Field menu option.
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Auto-detect Symmetry

Figure 2.3: Changing the molecular mechanics force field.
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2.3 Symmetrizing Structures

If your molecule has symmetry, the MM optimization is unlikely to find a structure with
the desired symmetry. If this is the case, a nearly symmetric structure can be symmetrized
using the Build » Symmetrize Molecule menu option. Finding very high symmetry may
require relaxing the tolerance using the Build » Set Symmetry Tolerance menu option.
Relaxing the tolerance allows the program to move the nuclear coordinates more in order
to find a symmetric structure.

[QMOL uses a modified version of the SYMMOL[I] program written by Tullio Pilati and
Alessandra Forni to symmetrize molecular structures.

2.4 Specifying Geometric Parameters

Specific values for geometric parameters can be set by first selecting the atoms involved
and using the Build » Set Geometric Constraint menu option. A dialog will appear that
allows the parameter to be either set, constrained or scanned. Constrained parameters
apply to any subsequent MM optimization and are also passed through to the Q-CHEM
input file, if a optimization job is requested. Scan options are also passed through to
(Q-CHEM for scan jobs.

800 @ Configure Angle

(s)Set () Constrain ( )Scan Angle between atoms 1-2-3

32.94° |[3]

| cancel | | Apply |

Figure 2.4: Dialog for setting geometric constraints

The type of constraint depends on the number of atoms selected:
1. Fixed atom position
2. Inter-atomic distance (or select a single bond)
3. Bond angle
4. Torsion (dihedral) angle

Active constraints are visible in the Viewer and can be deactivated by clicking the adjacent
check-box in the MV.
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2.5 DManipulating and Selecting Molecules

IQMOL has been designed to work best with a three-button mouse or track pad. If you
are using a track pad on a Mac, it is recommended that you enable the secondary click
by going to System Preferences » Trackpad.

Manipulate mode is activated by clicking the D button in the Toolbar, and implements
the following mouse functionality:

e Left click and drag: Rotate the view of the molecule.

e Middle click and drag: Zoom in and out.

e Right click and drag: Translate the view of the molecule.
It is also possible to manipulate part of the molecule independently from the rest. To do
this, make a selection and press and hold the ctrl modifier (command key on Mac). The
mouse movements will affect only the selected atoms as follows:

e Left click and drag: Rotate the selected atoms about their center.

e Right click and drag: Translate the selected atoms.
If only a single bond is selected, then the mouse movements have the following effects

e Left click and drag: Rotate around the axis of the bond.

e Right click and drag: Change the length of the bond.

Select mode is activated by clicking the button in the Toolbar, and implements the
following mouse functionality:
e Left click: Adds atom or bond to selection.

e Click and drag: Creates a selection rectangle, all atoms and bonds within the
selection rectangle are added to the selection.

e Right click: Removes atom or bond from selection.

It is also possible to select all, select none and invert the selection via the options under
the Edit menu.

10
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2.6 Adding Additional Conformers

For setting up jobs that use the Freezing String Method (FSM), two conformers are
required corresponding to the initial and final geometries of the string. Having built the
first geometry, a second geometry can be added to the molecule by right-clicking the
molecule name in the MV. This brings up a context menu with the option ‘Duplicate
Geometry’. Selecting this menu option creates a Geometries item in the MV with two

Model View
» Global

» Info Configure
» Atoms Select All

» Bonds Reperceive Bonds
Surfac | Duplicate Geometry
Atomic Charges »

Remove
"

(identical) geometries. The second of these can be modified by selecting it in the MV and
manipulating selected atoms in the viewer using the ctrl (command on Mac) modifier key.
If ‘Freezing String’ is chosen for the Calculate option in the QUI (see the next section)
then both geometries will be included in the $molecule section of the input deck, separated
by *Hkk,

11



3 Running Q-Chem Calculations

3.1 The QUI

[QMOL has a built-in input file generator for Q-CHEM calculations, the QUI, that can be
accessed via the Calculation » Q-Chem Setup menu.

0006 IQmol )
- Advanced | Generated Input File:
Job Section | Job 1 s | Edit | E]
Calculate | Energy 4| Charge 0 \;\ or
o 6-31¢
Method  |HF| v | Multiplicity |1 %) -
.S, L — e
Basis 6-31G v | ECP | None v
Exchange HF v | Correlation |None
SCF Control
Algorithm | DIIS 4| Convergence |5 =)
Guess | sAD 4| Max Cycles 50 \;\
Second Basis | None 3| Cuess Mix 0%
|_| Dual Basis Energy |_| Unrestricted

Server | QChem

Wavefunction Analysis

| Reset | | Cancel | | Submit |

Figure 3.1: The Q-CHEM User Interface (QUI) dialog.

The left hand side of the QUI dialog contains controls for setting up the calculation. These
are presented in a hierarchical fashion so that most commonly used options are presented
in the top part of the panel, with other relevant options appearing in the lower section
depending on what type of job is selected. More advanced options can be accessed via
the Advanced tab. The generated input file is echoed in the panel on the right hand side
of the QUI.

Clicking the Submit button will start the job running on the selected server. Once the job
has completed you will be prompted to copy the results (for remote servers) before they
are automatically loaded into IQMOL. The wr icon appears next to the molecule name in
the MV when the molecule has been updated with the results of a calculation.
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Figure 3.2: The Job Monitor dialog. Right-clicking on a selected job brings up a context
menu with additional options.

3.2 The Job Monitor

Submitted jobs can be monitored via the Calculation » Job Monitor menu option. This
brings up the Job Monitor dialog that provides information on the progress of jobs. Right-
clicking a row in the Job Monitor brings up a context menu which allows running jobs to
be killed or queried, and finished jobs to be opened.

If a job has the Error status, hovering the mouse over the status will show the error
message. Alternatively, double clicking the job will open the output file, if available, and
may provide additional information about why the job failed. Double-clicking a completed
job will copy the results from the server (if they have not already been copied) and reload
them into the main IQMOL window.

3.3 Configuring Servers

By default IQMOL is configured to submit jobs to the Q-CHEM server in Pleasanton,
California. This is a publicly available server than can be used by anyone wishing to run
test calculations before purchasing the Q-CHEM software. Jobs submitted to this server
can access the full suite of electronic structure methods available in Q-CHEM, but are
time-limited to 10 minutes.

Additional servers can be configured to access other computers that have the Q-CHEM
software installed. These computers can be either local servers (i.e. the same machine
as the one running IQMOL) or remote servers that can be connected to via SSH. To add

13
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Figure 3.3: The server configuration dialog.

an additional server, go to the Calculation » Edit Servers menu option and click the
button.

The information required to configure a server depends on its type, but default options
exist for each case. The following indicates the minimum that should be considered:

e Local: Set the Queue System to ‘Basic’ unless you know you are running queuing
software on the machine. Be sure the QC and QCSCRATCH variables are set to their
correct values in the Run File Template, which is accessed by clicking the Configure
button.

e SSH: The host name and account on the target machine will be required in order to
connect via SSH. Set the Authentication combo-box to ‘Password Prompt’ unless
you have set up an alternative authentication protocol. Depending on how the
target host has been set up, the Run File Template may require some editing to get
it to work, but this will differ from machine to machine.

e HTTP: The default options should be suitable. Note that on Windows HTTP
should be used (and is the default in v2.8) whereas for Mac and Linux HTTPS can
be used and will be the default in future versions.

14



4 Analyzing Results

IQMOL reads in a wide variety of file types and allows the user to visualize many of the
results they contain. Individual files can be opened via the File » Open menu option, or
alternatively by dragging and dropping the file onto the Viewer window. Directories can
also be opened via the File » Open Dir menu option, or by dragging and dropping the
directory onto the Viewer.

Opening directories allows more than one file associated with a molecule to be loaded
together, such as a |(Q-CHEM output file and a formatted checkpoint file. The directory
name determines the base name for the molecule and IQMOL loads all files contained
within the directory that have a matching base name.

o [ ] Aniline
< g2 =i =y %y H O Q
Favorites Aniline.ESP.cube

Aniline.FChk
Devices Aniline.inp
Aniline.out
7 notes.txt

Figure 4.1: Example: Opening the Aniline directory will load the Aniline.ESP.cube,
Aniline.FChk, Aniline.inp and Aniline.out files into the one molecule in the MV. The
notes.txt file will be ignored as it has a different base name.

4.1 Molecular Surfaces

Several molecular surfaces can be generated without first performing a quantum chemical
calculation. These include: van der Waals, pro-molecule and superposition of ionic den-
sities (SID). The SID surface is similar to the pro-molecule surface except that it scales
the densities based on the atomic charges of the atoms and may provide a more accurate
representation of the density of charged systems.

To plot one of these pseudo-density surfaces, double-click the ‘Surfaces’ item in the MV
associated with the molecule.

15
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4.2 Plotting Molecular Orbitals From a Checkpoint File

Plotting molecular orbitals (MOs) requires a formatted checkpoint file (.fchk file exten-
sion) which is generated by default when running Q-CHEM calculations from IQMOL
(GUI rem variable should be set to 2). After opening the fchk file, a ‘Canonical Orbitals’
item will appear in the MV under the Surfaces item. Double-clicking this brings up the
Add Surface dialog:

[ ] 0] @ Add Surface
Type: Alpha Orbital [
_ - -0.48
Orbitalls): = 24 (HOMO}) to 24 (HOMO)
talfe) - = -0.54 o ——
8
Isovalue:  D.020 |2 B Simplify Mesh £ 086 =
Quali A ==
uality:  Low _ High o
2 072}
w
Colors: - Negative - Positive -0.78 | o ——
i ==
) -0.84 L . L
Opacity: — =——— Alpha Beta
Cancel L — Beta orbital 24: -0.539 Eh

Figure 4.2: The Add Surface dialog allows MOs and (spin-)densities to be plotted.

The Add Surface dialog allows MOs, total densities, and spin densities to be computed.
Several surfaces can be queued and computed at the same time, which is more efficient
as the shell data only need to be computed once. The quality, colors and opacity of
the surfaces can be be set in the dialog, and changes to these settings are saved to the
preferences as default values for any subsequent surfaces generated.

Note that each tick on the quality scale corresponds to roughly four times the number
of grid points as the previous one, and will therefore take roughly four times as long to
compute. Also note that densities require evaluating shell-pair values and are significantly
more expensive to compute that MOs, which only require shell values. For most purposes,
the pseudo densities (such as the pro-molecule density) available by double-clicking the
Surfaces item provide an almost identical density surface, but at a much cheaper cost.

Once computed, the individual surfaces appear as sub-items in the MV, and these can be
further configured by double-clicking the item in the MV.

The Add Surface dialog also contains an interactive energy level diagram on the right-
hand side panel. The vertical scale can be zoomed in and out using the scroll wheel

16
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o/

Figure 4.3: An example molecular orbital for aniline.

(or equivalent) on the mouse. The scale can also be translated by a left click-and-drag.
Individual orbitals can be selected with a left-click and this will cause the energy of the
selected orbital to appear below the diagram, as shown in Fig. |4.2

4.3 Other Orbitals and Densities

Orbitals and densities other than those based on the canonical orbitals can also be vi-
sualized, if the appropriate calculation has been performed. Localized orbitals, natural
transition orbitals, natural bond orbitals and attachment/detachment densities are all
possible.

Figure 4.4: Localised o-bonding orbitals in ethene.

Dyson orbitals can be also displayed, either from the checkpoint file (requires

17
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> v5.1) or from the output file using an older version of Q-CHEM. In the latter case, the
PRINT_GENERAL_BASIS option should be set to true in order for IQMOL to generate
the basis function data.

$rem

METHOD = EOM_CCSD

BASIS = cc-pVIZ

EOM_EA_BETA = [1,1,1,0]

CC_DO_DYSON = TRUE

GUI =2

PRINT_GENERAL_BASIS = TRUE ! Ony required for QChem < vb.1
$end

If available, Dyson Orbitals appear under the Surfaces item in the Model View and behave
similarly to the Canonical Orbitals.

4.4 Exporting Cube File Data

Each surface requires the generation of data on a 3D grid and these data are stored
internally so that subsequent calculations of the same surface (with different isovalues,
for example) are much faster. To see what grid data is being stored, right-click on the
MO Surfaces item in the MV to bring up the context menu. Selecting the Show Grid Info
menu brings up the Grid Information dialog:

8.006 Grid Information
Type | DatasSize (kB)  Step Size 7.9 | Bounding Box
1 -
| Alpha 25 740.2 0.4330  (-5.97 [E_ry—"
2 | Alpha 26 740.2 0.4330 (-5.97  Export Cube File

Export Cube File (Switch Phase)
T

| Close |

Figure 4.5: The Grid Information dialog shows what data is being stored and offers the
option of exporting the data in a cube file format.

From this dialog it is possible to export cube files containing the grid data. Right-clicking
on the desired grid brings up a context menu with the Export Cube File option. The
Switch Phase option swaps the sign of the data, and may be useful when comparing
different MOs where the (arbitrary) phases differ. Cube files can be saved for future

18
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plotting to avoid having to recompute the data, or for reading into another plotting
package. This is described in the following section.

4.5 Visualizing Cube File Data

Cube files contain volumetric data such as electron densities, molecular orbitals or elec-
trostatic potentials (ESP). Because the data has been pre-computed, generating surfaces
using them is very quick. After opening a cube file, a Cube Data item will appear in the
MV, double-clicking this item brings up the Add Surface dialog which allows an isovalue
surface to be requested (Fig. |4.6). The Signed check-box causes two isosurfaces to be
generated corresponding to + the specified isovalue, and this should be checked for data
such as MOs and spin densities.

800 & Add Surface

Isosurface Value: |0.020 -]
™ signed (¥ Simplify Mesh
Colors: - Negative - Positive
| Cancel | " Calculate |
T

Figure 4.6: The Add Surface dialog for cube data files

Cube file data can also be used to color a surface. This will require either two cube files
(one containing the surface data and the second containing the property used to color the
surface) or a cube file and a checkpoint file. In either case, two files need to be loaded
into the one molecule using the File » Open Dir menu option, described above.

After creating a surface, double-clicking the surface item will cause the Configure Surface
dialog to appear:

The Property combo-box will have the cube data as one of the options, and selecting this
will cause the surface to be colored according to the data in the cube file. The gradient
colors can be altered by clicking inside the gradient box.

19
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Render (@Fill  Lines () Dots

Opacity “IClip

Surface Area: 172.528

Figure 4.7: Configure Surface dialog showing the Cube Data as an option for the property.

Figure 4.8: Electron density plot of aniline colored according to the electrostatic potential.
4.6 Orbital Animations

Orbital animations can be created e.g., for watching the evolution of the frontier orbitals
during a reaction, or watching the relaxation of an orbital during a self-consistent field
(SCF) calculation. Key frames should be saved as cube file data in a single directory.
The base name of the cube files needs to match the directory name, e.g.

relaxation/relaxation.Frame.1.cube
relaxation/relaxation.Frame.2.cube

Open the directory, as described in Sec. [}, and right-click on the first cube file item which
appears in the MV, this will allow you to access the Surface Animator dialog:

Model View
> Global
v Frame
> Info
» Files
> Atoms
» Bonds
Surfaces

Cube Data (Frame.2) -
Cube Data (Frame.1)  Surface Animator

20



The dialog is shown in Fig. and can be used to adjust the key frame order and the set-
tings for the animation, including the number of interpolation frames (higher values give

smoother results, but take longer). Pressing | Calculate] generates each frame and indi-
vidual frames can be accessed in the MV. Use the playback options to run the animation,

recording it with the button, if desired.

eCe Create Animation

Cube File Frames

Frame.1
Frame.2

Interpolation Frames 10 :

Surface Render

Render @ Fill  Lines | Dots
2 Simplify Mesh

Isovalue 0.020 |7

Colors - Negative - Positive

Opacity

Playback

Q8] (O

Loop Bounce Update Bonds

Speed

Cancel Calculate
T

Figure 4.9: The surface animation dialog.
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4.7 Potential Energy Surfaces

Several calculation types provide information about the potential energy surface (PES).
These include geometry optimizations, PES scans, reaction pathways and transition state
searches. On opening a Q-CHEM output file containing one of these job types a Geometries
item appears in the MV and can be double-clicked to bring up the Geometries dialog.

[ ] [ ] @ Geometries

Energy
1 -319.476896 -319.476 |
12 -319.477466
13 -319.478044
14 -319.478454
15 -319.478555
16 -319.478550
17 -319.478431
18 -319.478079
19 -319.477692
20 -319.477358

2 -310.477252

1
I I L L I I I L
-160  -120 -80 -40 0 40 80 120 160
Geometric Parameter

Leop Bounce Update Bonds

-319.477 -

-310.477 |

-319.478 -

Energy

-319.478 |

-319.478 -

Close

Speed

Figure 4.10: The Geometries dialog showing a selected geometry.

The pathway can be animated in the viewer using the play button, and individual frames
can be selected from either the table or by selecting a dot on the energy plot. The Viewer
window will be automatically updated with the corresponding structure. As with the MO
energy diagrams, the energy plot can also be zoomed and scrolled.

Pathways can also be read in from an XYZ file. The format for this is simply a concate-
nation of regular XYZ files:

5
-291.77177
Si 0.71979 -0.08082  -0.76577

H 0.73262 -1.27801 0.22990
H 1.10451 0.93673 0.34825
H -1.32980 0.23894  -0.28240
H -1.22713 0.18317 0.47002
5

-291.76961

Si 0.67218 -0.07483 -0.72935
0.73053  -1.29428 0.22634
1.10815 0.95270 0.34714

-1.29502 0.23567 -0.33016

-1.19409 0.17584 0.49156

j= =it =i =i
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The first line gives the number of atoms, the second (comment) line must have the cor-
responding energy and then the following lines have the xyz coordinates of each atom in
the system. This pattern repeats for as many frames as you have available.

4.8 Vibrational Frequencies

Vibrational frequencies can be read in from a Q-CHEM output file and appear as a
Frequencies item in the MV. Normal mode vectors can be visualized by selecting the
associated frequency item in the MV.

Figure 4.11: Arrows indicating a normal mode in acetic acid.

Double-clicking a frequency in the MV will cause the molecule to vibrate according to
the selected mode. Double-clicking the Frequencies item in the MV will bring up the
Vibrational Frequencies dialog:

This dialog contains an impulse spectrum showing the positions and relative intensities of
the frequencies. Individual modes can be selected on the spectrum by clicking the hollow
circles, and this will also update the Viewer window with the selected mode. The impulses
can be broadened using either Gaussians or Lorentzians to give a more realistic looking
spectrum, and the image can be exported by righ-clicking on the spectrum to bring up a
context menu.

The horizontal scale of the spectrum can be zoomed (using the scroll wheel on the mouse)
and translated (left-click and drag) to give greater detail.

4.8.1 Isotopic Substitution

IQMOL makes it easy to set up isotopic substitution loops for a Q-CHEM| vibrational
frequency calculation. First select the atoms you wish to substitute in the Viewer and
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8.006 Vibrational Frequencies

Frequency {cm %} | Intensity (km/mol}
9 1489.97 17.042
150
10 1499.59 9.339
|11 | 1842.67 156.812 125
12 2899.78 138.480 = 100
@
=
13 3043.48 2.576 a 75
14 3100.08 9.291 B
50
15 3163.28 10.507
25 - I
Color T %
NS S 3

L I L @l I
400 800 1200 1600 2000 2400 2800 3200 3600

i - b )
Amplitude = P, Frequency

Speed ey
™ Loop Scale Factor ‘1_0b0 |5|‘ (=) Impulse () Gaussian () Lorentzian (_J Width | Close |

Figure 4.12: The Vibrational Frequencies dialog.

then select the Build » Set Isotopes menu option. A dialog will appear that allows you
to change the isotope for the selected atoms, along with the ability to change the pressure
and temperature used for calculating the thermochemical data.. Once the masses have

[ ] [ ] @ Dialog

Temperature 29818 K | [ Pressure 1.00atm

Element Isotopic Mass Indicies
Hydrogen | H(2) E 3,4,5
Carbon C(std) ﬁ 1

Figure 4.13: Isotope substitution dialog allowing non-default masses to be specified for
the selected atoms. Note that only one non-default mass is allowed for each element type.

been selected, click OK and an Isotopes item appears in the MV containing the substi-
tution information. This can be edited or checked by double-clicking on the appropriate
Substitution item in the MV. Different substitutions can be set up by selecting different
atoms in the Viewer and/or different masses and these will be looped over in the Q-CHEM
frequency calculation. Each substitution loop only requires a re-weighting of the Hessian
before diagonalization and so multiple loops can be obtained very quickly once the Hessian
has been calculated.
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4.9 NMR Spectra

NMR shieldings and chemical shifts can be visualized using IQMOL. A |Q-CHEM calcu-
lation (JOB_.-TYPE = NMR) must first be run and the output file loaded into IQMOL.
Shielding constants can be displayed as atom labels in the viewer by selecting the Display
» Atom Labels » NMR option.

31.08 '

Figure 4.14: Propanol showing the NMR shieldings

An NMR item will appear on in the MV and double-clicking this brings up the NMR
Spectrum dialog.

® L] @ NMR Spectrum
Atom Shielding Chem. Shift
1 H 32.07 1.60
2 C 195.16
3 H 32.47 1.21
=
2
E
5 C 182.30 E
6 H 31.08 2,60 s
o
7 H 31.08 2.59
8 c 146.92
£l H 29.78 3.90 J
L . . L . )
9 7.5 [} 45 3 15 o
Spectrum Proton (1H) E Chemical Shift {(ppm)
Reference ™S <]
Method HF/6-31G a Impulse ) Spectrum Resolution Close

Figure 4.15: The NMR Spectrum dialog

Various spectra can be displayed (*H, *C etc.) and if a reference is available (e.g. TMS) for
the given level of theory, chemical shifts can also be displayed. Selecting rows in the table
will also highlight the corresponding atoms in the viewer for easy identification. If impulses
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are plotted, then these can also be selected to identify which atoms are responsible for

the selected signal.

As with the vibrational frequencies spectra, NMR spectra can be exported by right-
clicking on the image to bring up the context menu.
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5 Appearance

5.1 Viewer Camera

When viewing a molecule, the coordinates of the atoms and surfaces are fixed in the world
reference frame. When manipulating the molecule using the mouse (see § it is actually
the camera that changes position and orientation. If more precise control of the camera is
required (e.g. for reproducing a particular image), then the camera can be configured via
the Display » Camera menu option. By default the camera uses a perspective projection
to give better depth perception, but an orthographic projection can also be selected, if
required.

[ oy ) @ Configure Camera

Orthographic () Perspective FoV 456 | ]

Position r 1025 |2/ @ 90 I & 330

Reset | WECLSN

Figure 5.1: The Configure Camera dialog allows precise control over position and orien-
tation of the Viewer camera.

5.2 Clipping Planes

A Global clipping plane is available and can be viewed by enabling the Clipping Plane item
under Global in the MV. Clipping planes can be useful for showing surface information
without obscuring the underlying molecular structure. While selected, the clipping plane
can be arbitrarily translated and rotated using the manipulate selection mode described
in § 2.5] Alternatively, a precise orientation of the clipping plane can be set by double-
clicking the Clipping Plane item in the MV to open the configuration dialog.

Individual surfaces can be clipped, by selecting the Clip check-box in in the surface config-
urator dialog (see Fig. for each surface. Once a surface has been clipped, the clipping
plane remains active even if hidden by unchecking the Clipping Plane item check-box in
the MV.
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Figure 5.2: Image showing a clipped density surface allowing the underlying molecular
structure to be more easily seen.

5.3 Shaders

IQMOL uses GLSL shaders to enhance the appearance of the Viewer. Shaders can be made
active by going to the Display » Appearance menu option, and selecting the Shader panel.

[ JoN ] @ Appearance

Shader POV-Ray
Shader 3

Ambient

Diffuse

Highlights

Noise Intensity

Saturation

Shininess

Options

| Enhance Edges Enhance Transparency
Hemisphere Lighting

Lights

Front Highlight | |Left
Lower

Save As Default OK

Figure 5.3: Configuring shader options

Changes to the various shader options will take immediate effect and can be saved as the
default by clicking [Save As Default]. Some shaders have several lights associated with
them, and these can be turned on or off to give different lighting effects.
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5.4 Exporting POV-Ray Files

IQMOL can generate scene files (.pov) for use with an external POV-Ray package. POV-
Ray uses ray tracing algorithms to generate images of very high quality and resolu-
tion. POV-Ray is open source, but several official and unofficial packages exist with
pre-compiled binaries, in particular testing was done using the Mac version of MegaPOV.
Binaries can be downloaded from the following sites:

e Mac: http://megapov.inetart.net/povrayunofficial_mac

e Windows: http://www.povray.org/download

To export a scene file use the Edit » Generate POV-Ray Input menu option. Scene files
are plain text with instructions for the POV-Ray program, and can be edited by the user
for fine tuning before processing. IQMOL can apply several effects (e.g. surface textures)
to the molecule, and these can be configured by opening the Appearance dialog (Display
» Appearance menu option).

[ JoN ] @ Appearance
Shader m
Phong shader settings are used for lighting

Global
Height 480 || Width 640 |C
Background Black a
Gamma 3.0 |

Textures
Atom Rough u
Bond Crumpled u
Surface = Bubble %]

OK

Figure 5.4: Appearance dialog showing Options for POV-Ray scene files.

Note that IQMOL attempts to generate a scene file that matches as closely as possible
what is shown in the Viewer window. However, there may be slight variations in lighting,
color and camera angle, and some trial and error may be required to obtain a pleasing
image. In particular, the Gamma value may need experimenting with, and changes to the
ambient and diffuse lighting (via the shader options) may be required depending on if a
light or dark background is selected for the scene.

29


http://iqmol.org
http://megapov.inetart.net/povrayunofficial_mac
http://www.povray.org/download
http://iqmol.org
http://iqmol.org

6 Sample Images

Here are some examples of the kinds of images that can be generated using IQMOL’s
shader and rendering options. Most of these are simply screen shots, however, tiles 3, 4
and 5 in the middle row were obtained by running POV-Ray on the IQMOL generated
scene file.
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